I suggest you ...

Autoprintr suggestion

Hi guys,

Here's a quick note about Multi-store operations and how the current Cloud Print service works;

When Store A makes an invoice, and Store B presses "Print", it will print to Store A, even though Store B pressed print.

I would love to see an option where, in AutoPrintr, no matter which store makes the invoice, whichever store *requests* the print, gets the print.

I would also suggest that for Dymo labels, if possible.

Thanks,
Don

1 vote
Vote
Sign in
(thinking…)
Password icon
Signed in as (Sign out)
You have left! (?) (thinking…)
Don Douglas shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

27 comments

Sign in
(thinking…)
Password icon
Signed in as (Sign out)
Submitting...
  • Ryan (CTO, Pinellas Computers) commented  ·   ·  Flag as inappropriate

    @Andrew: I can contest that the software is working 100% for over a week on our 2012 R2 Servers. Definitely check your network resiliency and machine's network monitor.

  • AdminTroy (Founder, RepairShopr) commented  ·   ·  Flag as inappropriate

    @andrew / others - at this point the software is getting pretty stable, so we'd like to have everyone just open a support ticket going forward instead of comment here unless it's to add functionality.

    Just open a ticket and we'll help out!

  • Andrew commented  ·   ·  Flag as inappropriate

    Hello. We installed autoprintr and it functioned fine for several hours. Now it has stopped functioning for all printers. It seems as if it has fallen asleep or something similar to that. Any thoughts? The computer it is on is a windows 7 computer and is not asleep or anything similar.

  • Ryan (CTO, Pinellas Computers) commented  ·   ·  Flag as inappropriate

    @Troy: Disregard that last message. Everything works, we were just not getting prints because we had the "register" dropdown set to the stores register. We don't use 80mm receipts and it looks like that bugs everything when that dropdown is set on a non-receipt printer.

    Also, attempting to save the config.json file (for the purpose of upgrading and not needing to re-enter all settings) and attemps to merge all our locations config.json files together (so we don't have to have a bunch of backup files) didn't appear to work. Although the authenication holds, jobs didn't hit the print queue. Would be nice if config data could remain even after upgrades. Just a thought.

    Sorry for the bad call last message. Thanks!

  • Ryan (CTO, Pinellas Computers) commented  ·   ·  Flag as inappropriate

    @Troy: Confirmed beta6 was working on servers. However, I was testing some modifications (copying and merging data from the config.json file) and now I can't get it to run, even after a fresh extraction of the files to a new directory. It runs and authenticates me, I set my location and printer settings, but nothing gets to the AutoPrintr queue. Login is correct, settings are saved and applied, print button says print job is sent: but no joy.

    Do you have some type of login threshold or max logins per time period blocking this from working? Currently, I'll need to be able to login/auth all our locations rapidly since I'm the only one with all locations auth'd. Any other ideas why jobs won't get to the queue?

    Also, running into a debug crash when I run as non-admin and enter in settings. If I run after that as admin, the app crashes and won't open. I end up having to delete the files and re-extract in order to get the app to even open.

    Please advise. Should we move updates/comments on AP to another thread?

  • AdminTroy (Founder, RepairShopr) commented  ·   ·  Flag as inappropriate

    If you want to try just for fun, try selecting all locations and see if print jobs come - in my testing they didn't come when I had something funky with the location.

  • Ryan (CTO, Pinellas Computers) commented  ·   ·  Flag as inappropriate

    Hey Troy. Installed beta5 on our Server 2012R2 and a Win10 PC. Both no joy at all. Can't even get a job tied to location A, to print at location A, while logged into location A. No jobs print at all.

    Tested printers in local OS environment and they both work from notepad. Tried logging out, deleting the app folder, redownloading, unchecking locations, etc. All don't work. I'm running as admin; when I tried running as non-admin; got an 'unhandled exception' error and it crashed.

    Something is missing. Let me know.

  • Ryan (CTO, Pinellas Computers) commented  ·   ·  Flag as inappropriate

    Update just now: I was logged in at location B and print a job located at location A. It successfully printed to me at location B - as you designed. Then cleared my location to GodMode and it printed to location A as I wanted it to. Great!

  • Ryan (CTO, Pinellas Computers) commented  ·   ·  Flag as inappropriate

    1. Didn't encounter an issue selecting 'save' with locations. The issue was just that ALL print jobs would come into the location, even when only 1 location was enabled. Right now we're auth'd on all servers with my credentials (I'm the only one with all locations auth'd) and it's working. I just need @David to be able to auth servers in the future.

    2. Understood. But I figured the security group 'Printers - Manage' already let you do this for GCP? Only if a user had that permission enabled would they be able to configure, and that's fine because they'd be specifically granted that permission.

    3. Yes, printing is much faster. Jobs hit AutoPrintr in < 1-2 seconds. The Windows spooler service takes longer than that.

  • AdminTroy (Founder, RepairShopr) commented  ·   ·  Flag as inappropriate

    @ryan / etc - I noticed an issue with the location selection, if you uncheck one and then check the right one - the save button works - you do need to hit save for that to start filtering on location.

    It seems like it could be a security issue to get print jobs for a location nobody has access to to me. I'd prefer if the person with access signs in at first. The app only needs the credentials for that moment - it's not going to leak access at all.

    Is it printing much faster for you guys?

  • Ryan (CTO, Pinellas Computers) commented  ·   ·  Flag as inappropriate

    @Troy: Working pretty great so far! Recap of findings and feedback so far with beta4:

    1. Executable working 100% for printing to the location the invoice is located at. :-)
    2. Printing in GodMode does properly print to the file to the location it is located at. Nice!
    3. As David stated, when at location B and printing invoice from location A, only prints at location A and not B. Heard on this being fixed in beta5.
    4. Authenticating into the exe only allows users to select locations they are privileged to. Can we make any user who has security group "Printers - Manage" be able to set any location inside the exe? They only need to see other locations for this one purpose.

    So far, this is twice as good as GCP and I only see it getting better. Kudos @RS!

  • David commented  ·   ·  Flag as inappropriate

    @Troy cool beans, look forward too it! and yes I have the location specified.

  • David commented  ·   ·  Flag as inappropriate

    With Beta 4 this is still happening to us. If store A has the autoprintr running and store B is using cloud print. Store B will print a ticket and store A will get it.

    This happens even if Store B is on google cloud print and not running autoprntr. Even IF store A's printers are removed from /printers and google cloud print.

    However this does NOT happen in reverse. If store A prints a ticket, only store A will get it.

    Also I 100% love that this is happening! Please keep up the great work! GCP was my BIGGEST headache in my infrastructure!

  • AdminTroy (Founder, RepairShopr) commented  ·   ·  Flag as inappropriate

    @ryan - can you try beta4, it's at the same link.

    Print jobs are auto-printing for me, I'd like to see if they start working for you..

    It will be a service once we are feature-complete, couple weeks still..

    Still have to add register support.

← Previous 1

Feedback and Knowledge Base